Site Search

Online Banking Security Update

Please verify your browser settings

To provide the most secure Online Banking experience possible, SF Police Credit Union will be making some changes to comply with best practices mandated by the Payment Card Industry Data Security Standard (PCI DSS).

As of May 24, 2018, members must have TLS (Transport Layer Security) version 1.1 or 1.2 enabled in order to use our Online Banking platform.

Although most devices/browsers currently support TLS 1.1 and TLS 1.2, there is a possibility that you may need to update your browser version or settings, especially if you aren't using the most current version of your web browser.

Why is this change necessary?


SFPCU is making this change to bring you the most secure Online Banking experience possible.

TLS (Transport Layer Security) is a protocol that works with your web browser to keep web applications such as SFPCU's Online Banking secure. According to industry best practices and PCI (Payment Card Industry) mandates, web browsers that only use older versions of TLS (1.0) are not secure enough by today's standards, leaving information vulnerable to cyber attacks.

In the interest of our members' security, we are requiring that members use web browsers that support TLS 1.1 or higher in order to access Online Banking.

The majority of web users are already using a browser that supports TLS 1.1. If your browser isn't up to date yet, just follow the guidelines below for instructions on updating your browser version and settings.

 

Why am I seeing a "Stronger Security is Required" message?

If you're trying to access Online Banking after May 24, 2018 and you see a "Stronger Security is Required" message, you are most likely using a web browser that doesn't support TLS 1.1 or higher.

To upgrade your web browser and/or enable TLS 1.1 and 1.2, please follow the guides at the bottom of this web page.

Stronger Security Required Message

How to enable TLS 1.1 and TLS 1.2

1.) Please ensure you are using the most recent version of one of these browsers.
The following web browsers support TLS 1.1 and 1.2.

Browser versions that support TLS 1.1 and higher
Microsoft Internet Explorer (IE) Version 11 and higher
Microsoft Edge All versions
Mozilla Firefox Version 27 and higher
Google Chrome Version 38 and higher
Apple Safari
  • Desktop: versions 7 and higher for OS X (Mavericks) and higher (7)
  • Mobile: versions 5 and higher for iOS 5 and higher
Android Lollipop 5.0 or higher

2.) Make sure that TLS 1.1 and 1.2 are enabled.
Once that you have verified you are using a supported browser, please ensure that you have TLS 1.1 and TLS 1.2 enabled by following the guides below.

Click here to validate your TLS settings ►

If you clicked on the button above and didn't receive a green check mark, below are some instructions for enabling TLS 1.1.

Internet Explorer 11

  • Open Internet Explorer
  • Select Internet Options from the menu
  • Navigate to the Advanced tab
  • Enable TLS 1.0, 1.1 and 1.2
  • Click Apply, then click OK.

Internet Explorer TLS Settings


























If you need to upgrade your version of Internet Explorer, click here to visit the Microsoft website.

Google Chrome

 

  • Open Google Chrome
  • Hit Alt+F on your keyboard and select Settings from the dropdown menu that appears.
  • Scroll down to the bottom of the Settings page and click on the Advanced link.

Chrome advanced settings

  • Scroll down to the System section and click on Open proxy settings...

Google Proxy settings

  • Select the Advanced tab
  • Scroll down to Security category and check the boxes for TLS 1.0, 1.1 and 1.2.
  • Click OK.

Google Chrome Settings

If you need to update your version of Google Chrome, click here to visit Google's website.

Firefox

Expand +Collapse -
  • Open Firefox
  • In the URL bar, type "about:config" and press Enter
  • Scroll down to "security.tls.version.max" and press Enter
  • Set the value to 3
  • Press the OK button

If you need to update your version of Firefox, click here to visit the Firefox website.

Apple Safari, Microsoft Edge, or Android
Expand +Collapse -
If you are using the most recent versions of these browsers/operating systems, TLS 1.1 and above are automatically supported.