Site Search
Security: Keep your browser up to date

Check Your Browser Compatibility

Starting May 24, 2018, members must have TLS (Transport Layer Security) version 1.1 or 1.2 enabled in order to use our Online Banking platform.

For more information on the TLS update, please visit https://www.sfpcu.org/tlsupdate 


green-check-mark

You are using:

Thank you! Your browser is up-to-date and compatible with all of our website’s features.

red-x-mark

You are using:

Your browser is not up-to-date. To experience all of our website’s features, please upgrade to one of our supported browsers.


Supported Browsers:

Why is it important to keep your browser up to date?

  • Outdated browsers cannot properly display all of the features our website and Online Banking platform have to offer
  • When you’re running the most up-to-date version of your web browser, you are running the most secure version of your web browser
  • Outdated browsers are vulnerable to hackers and put your personal information at risk